The Week Of Monday 9 May 2016 Archives by thread
Starting: Mon May 9 00:28:59 CDT 2016
Ending: Sun May 15 21:52:20 CDT 2016
Messages: 802
- [swift-evolution] Typealiases in protocols and protocol extensions
Xiaodi Wu
- [swift-evolution] Allow FloatLiteralType in FloatLiteralConvertible to be aliased to String
Morten Bek Ditlevsen
- [swift-evolution] Dropping NS Prefix in Foundation
Xiaodi Wu
- [swift-evolution] [Pitch] Require tuple conversions to be explicit when labels don't match
Jacob Bandes-Storch
- [swift-evolution] multi-line string literals.
Vladimir.S
- [swift-evolution] Should we rename "class" when referring to protocol conformance?
Andrew Trick
- [swift-evolution] Dropping NS Prefix in Foundation
Haravikk
- [swift-evolution] unums in Swift?
Stephen Canon
- [swift-evolution] Modify optional method semantics for swift
Carlos Rodríguez Domínguez
- [swift-evolution] [Pitch] Reducing the bridging magic in dynamic casts
Joe Groff
- [swift-evolution] [Accepted] SE-0072: Fully eliminate implicit bridging conversions from Swift
Joe Groff
- [swift-evolution] [Accepted] SE-0072: Fully eliminate implicit bridging conversions from Swift
Joe Groff
- [swift-evolution] [Pitch] Requiring proactive overrides for default protocol implementations.
Vladimir.S
- [swift-evolution] Feature proposal: Range operator with step
Thorsten Seitz
- [swift-evolution] [RFC] UnsafeBytePointer API for In-Memory Layout
Andrew Trick
- [swift-evolution] [Pitch] Consistent bridging for NSErrors at the language boundary
Charles Srstka
- [swift-evolution] [Pitch] Reducing the bridging magic in dynamic casts
Joe Groff
- [swift-evolution] [Pitch] Reducing the bridging magic in dynamic casts
Charles Srstka
- [swift-evolution] [Review] SE-0085: Package Manager Command Names
Daniel Dunbar
- [swift-evolution] [Review] SE-0086: Drop NS Prefix in Swift Foundation
Douglas Gregor
- [swift-evolution] Should we rename "class" when referring to protocol conformance?
Matthew Johnson
- [swift-evolution] Should we rename "class" when referring to protocol conformance?
Matthew Johnson
- [swift-evolution] Should we rename "class" when referring to protocol conformance?
Matthew Johnson
- [swift-evolution] Should we rename "class" when referring to protocol conformance?
Matthew Johnson
- [swift-evolution] [Review] SE-0074: Implementation of Binary Search functions
Brent Royal-Gordon
- [swift-evolution] [Proposal] More lenient subscript methods over Collections (was: [Proposal] Safer half-open range operator)
Brent Royal-Gordon
- [swift-evolution] [Review] SE-0074: Implementation of Binary Search functions
Nate Cook
- [swift-evolution] [Proposal] More lenient subscript methods over Collections (was: [Proposal] Safer half-open range operator)
Patrick Smith
- [swift-evolution] NSRange and Range
Douglas Gregor
- [swift-evolution] Move where clause to end of declaration
Douglas Gregor
- [swift-evolution] multi-line string literals.
John Holdsworth
- [swift-evolution] Change `repeat` to loop indefinitely if no while clause is present
Nicholas Maccharoli
- [swift-evolution] [Swift 4] Support an official reactive library
James Campbell
- [swift-evolution] [proposal] Allow function argument type to be omitted when passing a default value from which it can be inferred
Sam Dods
- [swift-evolution] [proposal] Treat (case .Foo = bar) as a Boolean expression
Sam Dods
- [swift-evolution] [RFC] #Self
Erica Sadun
- [swift-evolution] multi-line string literals.
Thorsten Seitz
- [swift-evolution] [Review] SE-0074: Implementation of Binary Search functions
Joe Groff
- [swift-evolution] [proposal] extra if syntax
MobileSoft (Piotr)
- [swift-evolution] [Accepted] SE-0082: Package Manager Editable Packages
Anders Bertelrud
- [swift-evolution] [Review] SE-0041: Updating Protocol Naming Conventions for Conversions
Chris Lattner
- [swift-evolution] [Review] SE-0075: Adding a Build Configuration Import Test
Chris Lattner
- [swift-evolution] [Review] SE-0081: Move where clause to end of declaration
Chris Lattner
- [swift-evolution] [Review] SE-0083: Remove bridging conversion behavior from dynamic casts
Chris Lattner
- [swift-evolution] [Review] SE-0084: Allow trailing commas in parameter lists and tuples
Chris Lattner
- [swift-evolution] (Draft) Add last(where:) and lastIndex(where:) methods
Nate Cook
- [swift-evolution] [proposal] default returns
Eduardo Mourey Lopez Ne
- [swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions
Chris Lattner
- [swift-evolution] [Pitch] Tuple Destructuring in Parameter Lists
Dennis Weissmann
- [swift-evolution] Standard library 'Data' type pre-proposal
Austin Zheng
- [swift-evolution] [proposal] Treat (case .Foo = bar) as a Boolean expression
Thorsten Seitz
- [swift-evolution] [proposal] Allow function argument type to be omitted when passing a default value from which it can be inferred
Thorsten Seitz
- [swift-evolution] Pitch: Soft unwrapping of optionals
Basem Emara
- [swift-evolution] [RFC] #Self
Thorsten Seitz
- [swift-evolution] Pitch: Soft unwrapping of optionals
Thorsten Seitz
- [swift-evolution] Re-Visit Proposal: Weak Native Swift Containers (12 2015)
dominik at pich.info
- [swift-evolution] [proposal] Allow "let" for computed properties which only reference immutable data
Alexander Momchilov
- [swift-evolution] Fwd: [Review] SE-0084: Allow trailing commas in parameter lists and tuples
Thorsten Seitz
- [swift-evolution] [review] SE-0088: Modernize libdispatch for Swift 3 naming conventions
Darren Mo
- [swift-evolution] [Review] SE-0084: Allow trailing commas in parameter lists and tuples
Erica Sadun
- [swift-evolution] Why can't protocols define constants or subtypes?
Charles Srstka
- [swift-evolution] [Pitch] Constrains for numeric types: Int<1...10> Double<0.0...1.0>
Adrian Zubarev
- [swift-evolution] [Pitch] Constrains for numeric types: Int<1...10> Double<0.0...1.0>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Tony Allevato
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Thorsten Seitz
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Jordan Rose
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Tony Allevato
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Matthew Johnson
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Matthew Johnson
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Thorsten Seitz
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Thorsten Seitz
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Tino Heth
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Austin Zheng
- [swift-evolution] [Pitch] Align @objc inference with the semantic model
Douglas Gregor
- [swift-evolution] SE-0088: Modernize libdispatch for Swift 3 naming conventions
William Shipley
- [swift-evolution] [Review] SE-0084: Allow trailing commas in parameter lists and tuples
Douglas McKenna
- [swift-evolution] [Accepted] SE-0060: Enforcing order of defaulted parameters
Chris Lattner
- [swift-evolution] [Rejected] SE-0073: Marking closures as executing exactly once
Chris Lattner
- [swift-evolution] [Rejected] SE-0074: Implementation of Binary Search functions
Chris Lattner
- [swift-evolution] [Accepted with Revision] SE-0076: Add overrides taking an UnsafePointer source to non-destructive copying methods on UnsafeMutablePointer
Chris Lattner
- [swift-evolution] [Accepted with Revision] SE-0080: Failable Numeric Conversion Initializers
Chris Lattner
- [swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions
Dan Appel
- [swift-evolution] Optional assignment operator
Jose Manuel Sánchez Peñarroja
- [swift-evolution] [Pitch] Nesting types without nesting in place (additional)
Adrian Zubarev
- [swift-evolution] Swift 3 and cross platform development
Michael Peternell
- [swift-evolution] Allowing `guard let self = self else { … }` for weakly captured self in a closure.
Hoon H.
- [swift-evolution] [Review] SE-0084: Allow trailing commas in parameter lists and tuples
Антон Жилин
- [swift-evolution] Referencing zero-parameter functions
Douglas Gregor
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Xiaodi Wu
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Patrick Smith
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
David Hart
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Vladimir.S
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Joe Groff
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Vladimir.S
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Nicola Salmoria
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Vladimir.S
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Matthew Johnson
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Thorsten Seitz
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Vladimir.S
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Nicola Salmoria
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Austin Zheng
- [swift-evolution] [Pitch] Consistent bridging for NSErrors at the language boundary
Charles Srstka
- [swift-evolution] [Pitch] Add toplevel keyword for protocols
Patrick Pijnappel
- [swift-evolution] [proposal] Allow "let" for computed properties which only reference immutable data
Andru Felipe Zuniga
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Thorsten Seitz
- [swift-evolution] [Draft] Introducing StaticSelf, an Invariant Self
Thorsten Seitz
- [swift-evolution] Fwd: [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Thorsten Seitz
- [swift-evolution] Removing "_ in" from empty closures
Rob Napier
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Thorsten Seitz
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Matthew Johnson
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Austin Zheng
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Austin Zheng
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Vladimir.S
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Austin Zheng
- [swift-evolution] [Pitch] merge types and protocols back together with type<Type, Protocol, ...>
Adrian Zubarev
- [swift-evolution] [Review] SE-0045: Add scan, prefix(while:), drop(while:), and iterate to the stdlib
Erica Sadun
- [swift-evolution] Could enums have their rawValue type inferred?
Eric Miller
- [swift-evolution] Interspersing guard let with guard boolean
Erica Sadun
- [swift-evolution] [draft-proposal] allow access to the underlying collection of a slice
Max Moiseev
- [swift-evolution] Is SE-0088 (Modernize libdispatch for Swift 3 naming conventions) open for comments?
Josh Osborne
- [swift-evolution] [Pitch] Consistent bridging for NSErrors at the language boundary
Jon Shier
- [swift-evolution] [Idea] "guard not let" optional binding
Karl
- [swift-evolution] Small Enhancement Request for Swift Protocol
Sreejith K R
- [swift-evolution] Could enums have their rawValue type inferred?
Eric Miller
- [swift-evolution] [Review] SE-0081: Move where clause to end of declaration
L. Mihalkovic
- [swift-evolution] Allow commits or branches in the Swift Package Manager instead of Version
Tyler Fleming Cloutier
- [swift-evolution] Union instead of Optional
Cao Jiannan
- [swift-evolution] Union instead of Optional
Cao Jiannan
- [swift-evolution] "AnyValue", "protocol MyProtocol : value" as counterpart to "AnyObject", ": class"
Karl
- [swift-evolution] Fwd: Union instead of Optional
Cao Jiannan
- [swift-evolution] Make access control private by default.
Knut Lorenzen
Last message date:
Sun May 15 21:52:20 CDT 2016
Archived on: Tue May 17 12:37:12 CDT 2016
This archive was generated by
Pipermail 0.09 (Mailman edition).