[swift-evolution] [Proposal] More lenient subscript methods over Collections
svabox at gmail.com
Thu May 12 06:08:19 CDT 2016
If there is a method with such name in Range(with equal meaning) - then it
seems like `clamping` will be the best solution here.
(as non-native speaker I don't feel this word is often used especially in
software development, but.. it seems like anyone who is writing in Swift
must be strong native English speaker/writer :-P I also mean all these
naming conversions, verb/noun, -ing/-ed/-able etc ;-) )
On 12.05.2016 12:56, Luis Henrique B. Sousa wrote:
> Yes, it would really be more consistent. "within" sounds great to me as
> well, but I don't know if there is a naming convention for it.
> I am okay to change our proposal to have those labels as two verbs -
> instead of a preposition and a verb - as suggested by @Brent.
> More opinions?
> - Luis
> On Thu, May 12, 2016 at 7:25 AM, Brent Royal-Gordon <brent at architechies.com
> <mailto:brent at architechies.com>> wrote:
> > It sounds good, thanks for you suggestions @Vladimir, @Patrick and @Brent.
> > I've just updated the proposal:
> > https://github.com/luish/swift-evolution/blob/more-lenient-subscripts/proposals/nnnn-more-lenient-collections-subscripts.md#detailed-design
> > - Luis
> Hmm. If you're going with `checking` for one of them, perhaps the other
> should be `clamping` (for the analogous method on `Range`, which you
> might want to use in the implementation of that subscript). That would
> create a nicely matched pair:
> array[checking: 0..<10]
> array[clamping: 0..<10]
> Brent Royal-Gordon
More information about the swift-evolution