[swift-evolution] [swift-build-dev] [Review] SE-0085: Package Manager Command Names
matthew at anandabits.com
Tue May 10 12:53:40 CDT 2016
Sent from my iPad
> On May 10, 2016, at 11:38 AM, Rick Ballard <rballard at apple.com> wrote:
>>> On May 10, 2016, at 8:49 AM, Matthew Johnson via swift-build-dev <swift-build-dev at swift.org> wrote:
>>> On May 10, 2016, at 2:19 AM, Dan Appel via swift-evolution <swift-evolution at swift.org> wrote:
>>> +1 to `swift package` being a little too verbose. However, I like the alternative `swift pm`/`swiftpm` (as noted in the proposal) even less. I have already been referring to the package manager as SPM, so IMO that name does not lose out on any clarity while also allowing it to be terse enough for every day use.
>>> I would not be against having both `spm` and `swift package` as Honza suggested.
>> + 1 to the proposal in general and also to adding the `spm` alias.
> Question for those of you who are advocating for a "spm" alias: Do you have a strong argument / preference for "spm" vs "swiftpm"? Personally I have been abbreviating the project as "swiftpm" and not "spm" when I talk about it, and have been trying to push that as the preferred abbreviation. "spm" is a few less keystrokes, but is a much more generic, less googleable name; out of context, it's impossible to know what it refers to. Once the project gets enough mindshare, like "npm" has, that might be less of an issue, but I still personally prefer the more descriptive "swiftpm". Thoughts?
I prefer spm. Given the sponsorship by Apple I think mindshare is a matter of time. That said, I wouldn't oppose swiftpm either if that has more support.
> - Rick
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution