[swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Cole Campbell cole.m.campbell at icloud.com
Wed May 11 10:10:14 CDT 2016

> My main piece of feedback is that the method names synchronously() and asynchronously() don’t conform to Swift 3 naming conventions for functions and methods:

I agree.

> dispatchAsynch()
> dispatchSynch()

I prefer something like this. It feels more Swifty. As it is, they aren't any longer than asynchronously(), if name length is a concern.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160511/3fc168f6/attachment.html>

More information about the swift-evolution mailing list