[swift-evolution] [swift-evolution-announce] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Chris Lattner clattner at apple.com
Fri May 13 00:02:00 CDT 2016


On May 12, 2016, at 12:59 AM, Dennis Weissmann via swift-evolution <swift-evolution at swift.org> wrote:
>>> let item = DispatchWorkItem(qos: .qosUserInitiated) {
>>>     print("Hello World")
>>> }
>>> 
>>> I’d change the enum case from .qosUserInitiated to .userInitiated (maybe that’s just a typo since in the code example before uses .unspecified).
>> 
>> I think it is a typo, only default needs to be qosDefault because default is a keyword, and asking all users to back-tick it isn’t really good either.
>> (also no one should really specify qos class default anyway).
> 
> Even .default should be okay once SE-0071 <https://github.com/apple/swift-evolution/blob/23da9e94fd9580e59bdae50abf122d3d3c852a8f/proposals/0071-member-keywords.md> is implemented.

SE-0071 is implemented already.

-Chris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160512/b3300548/attachment.html>


More information about the swift-evolution mailing list