[swift-evolution] [Proposal] More lenient subscript methods over Collections
Luis Henrique B. Sousa
lshsousa at gmail.com
Thu May 12 04:56:24 CDT 2016
Yes, it would really be more consistent. "within" sounds great to me as
well, but I don't know if there is a naming convention for it.
I am okay to change our proposal to have those labels as two verbs -
instead of a preposition and a verb - as suggested by @Brent.
On Thu, May 12, 2016 at 7:25 AM, Brent Royal-Gordon <brent at architechies.com>
> > It sounds good, thanks for you suggestions @Vladimir, @Patrick and
> > I've just updated the proposal:
> > - Luis
> Hmm. If you're going with `checking` for one of them, perhaps the other
> should be `clamping` (for the analogous method on `Range`, which you might
> want to use in the implementation of that subscript). That would create a
> nicely matched pair:
> array[checking: 0..<10]
> array[clamping: 0..<10]
> Brent Royal-Gordon
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution