[swift-evolution] [Review] SE-0041: Updating Protocol Naming Conventions for Conversions
david at hartbit.com
Tue May 10 17:56:07 CDT 2016
> * What is your evaluation of the proposal?
+1 for the idea of making the naming consistent
-1 for the actual chosen names
Even after reading the reasoning behind the choice of those words, it took me a time to scratch my head around it. It’s definitely not immediately obvious that Convertible is bi-directional.
I would have preferred something much more obvious (even if less grammatically correct):
-InputOutputProtocol or BidirectionalProtocol
-Outputable (got that from Haskell)
-InputOutputable or -Bidirectionalable
> * Is the problem being addressed significant enough to warrant a change to Swift?
> * Does this proposal fit well with the feel and direction of Swift?
Yes for the idea of making them consistent, no for the names.
> * If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?
Haskell uses Outputable.
> * How much effort did you put into your review? A glance, a quick reading, or an in-depth study?
Read the proposal several times.
More information about the swift-evolution