[swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Xiaodi Wu xiaodi.wu at gmail.com
Fri May 13 14:29:06 CDT 2016


More nits:

setHighWater(highWater:) and its ilk should should probably be
setHighWater(_:) and so on (I include among these setInterval(interval:),
setTargetQueue(queue:), etc.)

Similarly, in terms of conforming to Swift guidelines, I notice many
instances where labels repeat the parameter type, especially
DispatchWalltime. For instance, setTimer(walltime: DispatchWalltime,
leeway: DispatchTimeInterval)--not sure what to suggest here other than
point out that the first label is redundant.
On Fri, May 13, 2016 at 11:36 Matt Wright via swift-evolution <
swift-evolution at swift.org> wrote:

> [Apologies for the weird threading, I missed the original email to the
> list so I can’t reply to it directly]
>
> I just wanted to let the list know that I updated proposal SE-0088 to fix
> the typos and include a more complete listing of the Dispatch module after
> the transformations in the proposal have been applied. Additionally, I’ve
> been keeping up with some of the feedback in this review thread and looking
> to see which ones would be best applied to the proposal. Though it should
> be made clear, this particular update only covers fixing the
> inconsistencies in my original proposal and providing a more complete
> overview of the module layout.
>
> Similar to the changes in Foundation that are proposed on swift-evolution,
> I don’t expect all of the changes in libdispatch will be able to go through
> this process. As this is a large change (and, hopefully, a step forwards)
> to libdispatch I believe it is important to bring it to the swift-evolution
> list and take away your feedback for inclusion in future iterations of the
> module.
>
> Thanks again for your continued feedback,
> Matt
>
> > On Tue, May 10, 2016 at 9:39 PM, Chris Lattner via swift-evolution <
> swift-evolution at swift.org> wrote:
> > Hello Swift community,
> >
> > The review of "SE-0088: Modernize libdispatch for Swift 3 naming
> conventions" begins now and runs through May 17. The proposal is available
> here:
> >
> >
> https://github.com/apple/swift-evolution/blob/master/proposals/0088-libdispatch-for-swift3.md
> >
> > Reviews are an important part of the Swift evolution process. All
> reviews should be sent to the swift-evolution mailing list at
> >
> >         https://lists.swift.org/mailman/listinfo/swift-evolution
> >
> > or, if you would like to keep your feedback private, directly to the
> review manager.
> >
> > What goes into a review?
> >
> > The goal of the review process is to improve the proposal under review
> through constructive criticism and contribute to the direction of Swift.
> When writing your review, here are some questions you might want to answer
> in your review:
> >
> >         * What is your evaluation of the proposal?
> >         * Is the problem being addressed significant enough to warrant a
> change to Swift?
> >         * Does this proposal fit well with the feel and direction of
> Swift?
> >         * If you have used other languages or libraries with a similar
> feature, how do you feel that this proposal compares to those?
> >         * How much effort did you put into your review? A glance, a
> quick reading, or an in-depth study?
> >
> > More information about the Swift evolution process is available at
> >
> >         https://github.com/apple/swift-evolution/blob/master/process.md
> >
> > Thank you,
> >
> > -Chris Lattner
> > Review Manager
> >
> >
> >
> > _______________________________________________
> > swift-evolution mailing list
> > swift-evolution at swift.org
> > https://lists.swift.org/mailman/listinfo/swift-evolution
> >
> > _______________________________________________
> > swift-evolution mailing list
> > swift-evolution at swift.org
> > https://lists.swift.org/mailman/listinfo/swift-evolution
>
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160513/4644df43/attachment.html>


More information about the swift-evolution mailing list