[swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Cole Campbell cole.m.campbell at icloud.com
Wed May 11 10:58:34 CDT 2016

Sorry, I realized after seeing Darren's message that I made a mistake. The abbreviation doesn't end with 'h'. It should be:


> On May 11, 2016, at 10:10 AM, Cole Campbell via swift-evolution <swift-evolution at swift.org> wrote:
>> My main piece of feedback is that the method names synchronously() and asynchronously() don’t conform to Swift 3 naming conventions for functions and methods:
> I agree.
>> dispatchAsynch()
>> dispatchSynch()
> I prefer something like this. It feels more Swifty. As it is, they aren't any longer than asynchronously(), if name length is a concern.
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160511/98d97b38/attachment.html>

More information about the swift-evolution mailing list