[swift-evolution] [swift-build-dev] [Review] SE-0085: Package Manager Command Names
pgwsmith at gmail.com
Tue May 10 20:21:34 CDT 2016
I like the readability of `swiftpm` or even `swift package`, but `spm` is nice for typing.
This is a silly request: what if swift packages were called eggs? Like Ruby’s gems.
And I’ve no idea if there’s already an ‘egg’ tool out there:
> On 11 May 2016, at 3:35 AM, orta therox via swift-evolution <swift-evolution at swift.org> wrote:
> I agree, I think just `swiftpm` is a great mix of ease of use and discoverability, for exactly the reasons you propose. I’ve been trying to always use that when talking about Swift Package Manager for the last few months.
> I think this is also better than `swift xxx` due to swiftpm really being a different user context from `swift` commands. Yes, under the hood it’s doing swift-y things, but package management is not compiling.
> [ ·/ ] Orta Therox
>> w/ Artsy <http://artsy.net/>
>> CocoaPods <http://cocoapods.org/> / CocoaDocs <http://cocoadocs.org/> / GIFs.app <https://itunes.apple.com/us/app/gifs/id961850017?l=en&mt=12>@orta <http://twitter.com/orta> / orta.github.com <http://orta.github.com/>
>> On May 10, 2016, at 12:38 PM, Rick Ballard via swift-build-dev <swift-build-dev at swift.org <mailto:swift-build-dev at swift.org>> wrote:
>>> On May 10, 2016, at 8:49 AM, Matthew Johnson via swift-build-dev <swift-build-dev at swift.org <mailto:swift-build-dev at swift.org>> wrote:
>>>> On May 10, 2016, at 2:19 AM, Dan Appel via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>>>> +1 to `swift package` being a little too verbose. However, I like the alternative `swift pm`/`swiftpm` (as noted in the proposal) even less. I have already been referring to the package manager as SPM, so IMO that name does not lose out on any clarity while also allowing it to be terse enough for every day use.
>>>> I would not be against having both `spm` and `swift package` as Honza suggested.
>>> + 1 to the proposal in general and also to adding the `spm` alias.
>> Question for those of you who are advocating for a "spm" alias: Do you have a strong argument / preference for "spm" vs "swiftpm"? Personally I have been abbreviating the project as "swiftpm" and not "spm" when I talk about it, and have been trying to push that as the preferred abbreviation. "spm" is a few less keystrokes, but is a much more generic, less googleable name; out of context, it's impossible to know what it refers to. Once the project gets enough mindshare, like "npm" has, that might be less of an issue, but I still personally prefer the more descriptive "swiftpm". Thoughts?
>> - Rick
>> swift-build-dev mailing list
>> swift-build-dev at swift.org <mailto:swift-build-dev at swift.org>
>> https://lists.swift.org/mailman/listinfo/swift-build-dev <https://lists.swift.org/mailman/listinfo/swift-build-dev>
> swift-evolution mailing list
> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution