[swift-evolution] [Review] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Ricardo Parada rparada at mac.com
Wed May 11 09:14:20 CDT 2016

Jacob Bandes-Storch suggested:

synchronously(execute work: …)

So maybe that will conform to the API naming guideline?  Or would the verb have to be in the base name of the func?

Or perhaps:

synchronously(dispatch work: …)
asynchronously(dispatch work: …)

> On May 11, 2016, at 9:32 AM, James Dempsey via swift-evolution <swift-evolution at swift.org> wrote:
> The method names
> 	synchronously()
> 	asynchronously() 
> are both adverbs, not noun phrases or verb phrases.
> These methods have side effects, so each name should have a verb in it to make it a verb phrase.
> Since these are the methods where you actually dispatch a block into a queue
> dispatchSynchronously()
> dispatchAsynchronously()
> would include the verb in the name of the methods.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160511/19f44516/attachment.html>

More information about the swift-evolution mailing list