[swift-evolution] [Draft] Rename Sequence.elementsEqual
xiaodi.wu at gmail.com
Sun Oct 15 02:41:53 CDT 2017
On Sun, Oct 15, 2017 at 2:39 AM, Adam Kemp <adam.kemp at apple.com> wrote:
> > On Oct 15, 2017, at 12:26 AM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> > Hmm, I do think I can squash some of these suggestions into an explicit
> and very clear option:
> > equalsInIterationOrder(_:)
> I could live with that name.
> > We would then clarify the corresponding precedence function in the same
> > lexicographicallyPrecedesInIterationOrder(_:)
> but that one seems a bit unwieldy...
But let it never be said to be anything but crystal clear :) We could just
leave it alone though.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution