[swift-evolution] [Draft] Rename Sequence.elementsEqual

Adam Kemp adam.kemp at apple.com
Sun Oct 15 02:39:41 CDT 2017

> On Oct 15, 2017, at 12:26 AM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> Hmm, I do think I can squash some of these suggestions into an explicit and very clear option:
> equalsInIterationOrder(_:)

I could live with that name. 

> We would then clarify the corresponding precedence function in the same way:
> lexicographicallyPrecedesInIterationOrder(_:)

but that one seems a bit unwieldy...

More information about the swift-evolution mailing list