[swift-evolution] [Draft] Rename Sequence.elementsEqual

Adam Kemp adam.kemp at apple.com
Sun Oct 15 00:56:29 CDT 2017

> On Oct 14, 2017, at 10:32 PM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> Therefore, it is entirely OK (to me) if the result is something that is so obtuse as to be at first meaningless to most people.

I can’t speak for others, but it’s not ok with me. API is UX. It should be understandable and approachable. If this were a function that was considered dangerous and we wanted to discourage its use then maybe I could buy this argument, but I don’t think that’s quite the case here. Even if you don’t think it’s the best API to use or the most common it should still be named clearly. 

More information about the swift-evolution mailing list