[swift-evolution] Proposal to change Logical NOT Operator from exclamation mark ( ! ) to something else
devteam.codafi at gmail.com
Wed Feb 15 12:10:46 CST 2017
So you've identified the problem, but what do you propose as a solution here?
It should be noted that a (non-stdlib) language-level answer to this question has already been discussed and rejected (https://lists.swift.org/pipermail/swift-evolution/2015-December/000032.html).
2017/02/15 9:02、Sadiq via swift-evolution <swift-evolution at swift.org> のメッセージ:
> I would like to suggest to change Logical NOT Operator from ! to something else.
> It will increase the readability of the code and will avoid any confusion with the symbol used for force unwrapping of optional values.
> It would be easier for new programmers to learn Swift as the first language.
> I don't understand the rational behind using the same operator for two different purposes.
> Thanks and Regards,
> Mohammad Sadiq
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution