[swift-evolution] [Proposal] Add floor() and ceiling() functions to FloatingPoint

Xiaodi Wu xiaodi.wu at gmail.com
Wed Jun 29 13:06:13 CDT 2016

On Wed, Jun 29, 2016 at 12:12 PM, Stephen Canon via swift-evolution <
swift-evolution at swift.org> wrote:

> On Jun 29, 2016, at 1:10 PM, Matthew Johnson <matthew at anandabits.com>
> wrote:
> My criticism of the 'toNearestOrGreatest' still stands though.  I think
> this name is misleading given the stated semantics.  The name indicates
> "greater value" not "greater magnitude" which are opposites in the case of
> negative numbers.
> Yup, I agree.  I think I originally suggested `toNearestTiesAway`.  I’m
> not tied to that name specifically, but we should be clear that ties go
> away from zero, not up.

Agreed; `toNearestOrAwayFromZero` is the most accurate and consistent

> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160629/e076fac5/attachment.html>

More information about the swift-evolution mailing list