[swift-evolution] [Proposal] Add floor() and ceiling() functions to FloatingPoint
scanon at apple.com
Wed Jun 29 12:12:32 CDT 2016
> On Jun 29, 2016, at 1:10 PM, Matthew Johnson <matthew at anandabits.com> wrote:
> My criticism of the 'toNearestOrGreatest' still stands though. I think this name is misleading given the stated semantics. The name indicates "greater value" not "greater magnitude" which are opposites in the case of negative numbers.
Yup, I agree. I think I originally suggested `toNearestTiesAway`. I’m not tied to that name specifically, but we should be clear that ties go away from zero, not up.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution