[swift-evolution] [Proposal] Add floor() and ceiling() functions to FloatingPoint
scanon at apple.com
Wed Jun 29 13:07:28 CDT 2016
> On Jun 29, 2016, at 2:06 PM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> On Wed, Jun 29, 2016 at 12:12 PM, Stephen Canon via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>> On Jun 29, 2016, at 1:10 PM, Matthew Johnson <matthew at anandabits.com <mailto:matthew at anandabits.com>> wrote:
>> My criticism of the 'toNearestOrGreatest' still stands though. I think this name is misleading given the stated semantics. The name indicates "greater value" not "greater magnitude" which are opposites in the case of negative numbers.
> Yup, I agree. I think I originally suggested `toNearestTiesAway`. I’m not tied to that name specifically, but we should be clear that ties go away from zero, not up.
> Agreed; `toNearestOrAwayFromZero` is the most accurate and consistent description.
Worth noting that since this is the defaulted behavior, we can get away with a wordy description.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution