[swift-evolution] [Pitch] Renaming sizeof, sizeofValue, strideof, strideofValue

Jacob Bandes-Storch jtbandes at gmail.com
Thu Jun 2 00:03:16 CDT 2016

If it's worth continuing the discussion in this thread, I rather like the
MemoryLayout<T>.size idea. For discoverability, we might want to have
@availability(*, unavailable, message: "use MemoryLayout<T>.size, etc.")
public init(){}.


On Wed, Jun 1, 2016 at 9:55 PM, Xiaodi Wu via swift-evolution <
swift-evolution at swift.org> wrote:

> On Wed, Jun 1, 2016 at 11:28 PM, Erica Sadun via swift-evolution <
> swift-evolution at swift.org> wrote:
>> Upon accepting SE-0098, the core team renamed the proposed stdlib
>> function from dynamicType() to type(of:).  They write, "The core team
>> recognizes that this means that we should probably resyntax the existing
>> sizeof/strideof functions, but that should be a follow-on discussion."
>> Follow on discussion started. Have at it.
> See: http://thread.gmane.org/gmane.comp.lang.swift.evolution/15830
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160601/d713d15e/attachment.html>

More information about the swift-evolution mailing list