[swift-evolution] [Pitch] Renaming sizeof, sizeofValue, strideof, strideofValue

Xiaodi Wu xiaodi.wu at gmail.com
Thu Jun 2 00:10:30 CDT 2016

On Thu, Jun 2, 2016 at 12:03 AM, Jacob Bandes-Storch <jtbandes at gmail.com>

> If it's worth continuing the discussion in this thread, I rather like the
> MemoryLayout<T>.size idea. For discoverability, we might want to have
> @availability(*, unavailable, message: "use MemoryLayout<T>.size, etc.")
> public init(){}.

It's a nice syntax, but I'm not fully comfortable with the suggestion that
sizeofValue(), etc. should go.  Also, I wonder about the static vs. dynamic
type issue here (despite having started the last thread, I still haven't
sat down to think it through).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160602/c3e47780/attachment.html>

More information about the swift-evolution mailing list