[swift-evolution] [Pitch] Including yes/no in stdlib as aliases for true/false
panajev at gmail.com
Thu May 5 03:23:19 CDT 2016
I think the descriptive/natural language aspect of Objective-C and Cocoa was and is a strength that should be kept in Swift too.
It may be perceived as a pragmatist attempt to simplify the language somewhat or make it appear friendlier, but it is not a bad thing in and of itself.
[[iOS messageWithData:ideas] broadcast]
> On 5 May 2016, at 08:54, Tino Heth via swift-evolution <swift-evolution at swift.org> wrote:
> I have seen wrong usage of bool values in Objective-C many times, and although most of those weren't real problems, I'd rather prefer to be forced to use a single pair of words for true/false.
> If this single pair is true/false or yes/no (or even .yes/.no [enum]) isn't that important to me, so I'm less opposed to change the names instead of introducing an alias.
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution