[swift-evolution] Trial balloon: conforming sizeof, sizeofValue, etc. to naming guidelines
xiaodi.wu at gmail.com
Sun May 1 11:47:52 CDT 2016
I think I agree with you that stride(from:to:by:) is the better candidate
for renaming. But, ranges and strides are distinct in Swift, and I don't
think we want to confuse the two, especially since ranges and intervals are
already being merged. A few of us have some ideas about striding over
things, which I hope we'll discuss soon :) Out of scope for this proposal,
On Sun, May 1, 2016 at 11:29 Антон Жилин <antonyzhilin at gmail.com> wrote:
> Then why not rename stride(from:to:by:) to range(from:to:by:) ?
> I think, range is closer to what people coming from other languages expect
> to see.
> - Anton
> > With the renaming proposed above, stride(of:) will appear to be related
>> to stride(from:to:by:). This conflict arises from a pre-existing issue;
>> namely, the term "stride" is used to mean two different things. Although
>> moving the preposition only highlights the issue, one possible resolution
>> is to rename strideof(_:) to strideSize(of:) and strideofValue(_:)
>> I wonder if it might make sense to rename all of these, then?
>> Brent Royal-Gordon
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution