[swift-evolution] Trial balloon: conforming sizeof, sizeofValue, etc. to naming guidelines
antonyzhilin at gmail.com
Sun May 1 11:29:47 CDT 2016
Then why not rename stride(from:to:by:) to range(from:to:by:) ?
I think, range is closer to what people coming from other languages expect
> With the renaming proposed above, stride(of:) will appear to be related
> to stride(from:to:by:). This conflict arises from a pre-existing issue;
> namely, the term "stride" is used to mean two different things. Although
> moving the preposition only highlights the issue, one possible resolution
> is to rename strideof(_:) to strideSize(of:) and strideofValue(_:)
> I wonder if it might make sense to rename all of these, then?
> Brent Royal-Gordon
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution