[swift-evolution] SetAlgebra naming update
jdhillhouse4 at icloud.com
Thu Mar 24 22:07:41 CDT 2016
> On Mar 24, 2016, at 7:25 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> on Thu Mar 24 2016, Ricardo Parada <swift-evolution at swift.org> wrote:
>> Hi all,
>> I could get used to the formNoun naming convention for the mutable versions of the methods.
>> I would suggest the following changes:
>> Remove the parameter label from symmetricDifference() and formSymmetricDifference() to be consistent with the other methods.
>> Consider renaming:
>> subtracting / subtract
>> difference / formDifference
>> in order to keep the API consistent.
> The problem with “difference” is that it's not symmetrical; you really
> need to do something to clarify which is the minuend and which is the
> subtrahend (yes, I had to look those terms up to write this post!)
> subtract and subtracting make that clear.
Initially, I was 99% happy. My initial reservation had been with subtracting/subtract and thought that subtract/formSubtraction might have been better.
But with your clarification (and vocabulary for the day!) subtract and subtracting make sense and I’m 100% for the proposed SetAlgebra.
More information about the swift-evolution