[swift-evolution] SetAlgebra naming update
dabrahams at apple.com
Thu Mar 24 19:23:09 CDT 2016
on Thu Mar 24 2016, Xiaodi Wu <swift-evolution at swift.org> wrote:
> Much improved, IMO. A few thoughts:
> * typo in "formSymmetricDifference"
> * I don't know about the preposition "from" in "form symmetric difference
> from" (also, inconsistent, because you don't have "form union with")
Good point. What would you suggest? We could use “with:” everywhere in
the “formXXX” methods...
> * "form" is fine, but scans similarly to "from" when reading quickly
That's a good point. Maybe that's another good reason to drop “from:”
as a preposition in formSymmetricDifference.
> On Thu, Mar 24, 2016 at 3:41 PM Dave Abrahams via swift-evolution <
> swift-evolution at swift.org> wrote:
>> Just an update:
>> The naming guidelines working group went back into negotiation over
>> the shape of SetAlgebra (and thus, Set and OptionSet) for
>> Swift 3, and reached a new consensus. We intend to bring forward a
>> proposal for the API shown here:
>> and to update the guidelines to suggest using the "form" prefix to
>> create a verb phrase for a mutating method when the operation is
>> fundamentally non-mutating and described by a noun.
>> swift-evolution mailing list
>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution