[swift-evolution] SetAlgebra naming update
dabrahams at apple.com
Thu Mar 24 19:25:18 CDT 2016
on Thu Mar 24 2016, Ricardo Parada <swift-evolution at swift.org> wrote:
> Hi all,
> I could get used to the formNoun naming convention for the mutable versions of the methods.
> I would suggest the following changes:
> Remove the parameter label from symmetricDifference() and formSymmetricDifference() to be consistent with the other methods.
> Consider renaming:
> subtracting / subtract
> difference / formDifference
> in order to keep the API consistent.
The problem with “difference” is that it's not symmetrical; you really
need to do something to clarify which is the minuend and which is the
subtrahend (yes, I had to look those terms up to write this post!)
subtract and subtracting make that clear.
More information about the swift-evolution