[swift-evolution] SetAlgebra naming update
rparada at mac.com
Thu Mar 24 16:49:06 CDT 2016
I could get used to the formNoun naming convention for the mutable versions of the methods.
I would suggest the following changes:
Remove the parameter label from symmetricDifference() and formSymmetricDifference() to be consistent with the other methods.
subtracting / subtract
difference / formDifference
in order to keep the API consistent.
> On Mar 24, 2016, at 5:35 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
> Much improved, IMO. A few thoughts:
> * typo in "formSymmetricDifference"
> * I don't know about the preposition "from" in "form symmetric difference from" (also, inconsistent, because you don't have "form union with")
> * "form" is fine, but scans similarly to "from" when reading quickly
>> On Thu, Mar 24, 2016 at 3:41 PM Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
>> Just an update:
>> The naming guidelines working group went back into negotiation over
>> the shape of SetAlgebra (and thus, Set and OptionSet) for
>> Swift 3, and reached a new consensus. We intend to bring forward a
>> proposal for the API shown here:
>> and to update the guidelines to suggest using the "form" prefix to
>> create a verb phrase for a mutating method when the operation is
>> fundamentally non-mutating and described by a noun.
>> swift-evolution mailing list
>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution