[swift-evolution] SetAlgebra naming update
xiaodi.wu at gmail.com
Thu Mar 24 16:35:53 CDT 2016
Much improved, IMO. A few thoughts:
* typo in "formSymmetricDifference"
* I don't know about the preposition "from" in "form symmetric difference
from" (also, inconsistent, because you don't have "form union with")
* "form" is fine, but scans similarly to "from" when reading quickly
On Thu, Mar 24, 2016 at 3:41 PM Dave Abrahams via swift-evolution <
swift-evolution at swift.org> wrote:
> Just an update:
> The naming guidelines working group went back into negotiation over
> the shape of SetAlgebra (and thus, Set and OptionSet) for
> Swift 3, and reached a new consensus. We intend to bring forward a
> proposal for the API shown here:
> and to update the guidelines to suggest using the "form" prefix to
> create a verb phrase for a mutating method when the operation is
> fundamentally non-mutating and described by a noun.
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution