[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"
brent at architechies.com
Wed Dec 23 04:08:06 CST 2015
>> I did see that point made earlier in the thread, but I’m not convinced that design for googleability is the right ordering of priorities.
> Choosing cryptic names because it's easier to find information about them is bad. With this argument, you can not only fight against removal of the NextStep prefix (Data, Number, Date… try googling that), but also demand that the language should be spelled "Sweeft", and that framework functions should loose their meaningful names and get called by a UUID instead.
I don't think the `associated` keyword is cryptic; I think it's *specific*. "Associated type" is the name of this feature. We tried bikeshedding it upthread, and didn't come up with anything better. If you're going to use a keyword related to the name "associated type", that leaves you with `associated`, `type`, or `associatedtype`. Of these three, `type` is extremely vague (and also something we've resisted taking as a keyword—see the discussion about `SomeType.self` last week), `associatedtype` is an overlong, awkward concatenation of two words, and `associated` has neither of those failings. That's why I favor it.
More information about the swift-evolution