[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"

Tino Heth 2th at gmx.de
Wed Dec 23 03:59:42 CST 2015

> I did see that point made earlier in the thread, but I’m not convinced that design for googleability is the right ordering of priorities. 
Choosing cryptic names because it's easier to find information about them is bad. With this argument, you can not only fight against removal of the NextStep prefix (Data, Number, Date… try googling that), but also demand that the language should be spelled "Sweeft", and that framework functions should loose their meaningful names and get called by a UUID instead.

More information about the swift-evolution mailing list