[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"

James Campbell james at supmenow.com
Wed Dec 23 04:10:44 CST 2015

+1 for associated

On Wed, Dec 23, 2015 at 10:08 AM, Brent Royal-Gordon via swift-evolution <
swift-evolution at swift.org> wrote:

> >> I did see that point made earlier in the thread, but I’m not convinced
> that design for googleability is the right ordering of priorities.
> > +1
> > Choosing cryptic names because it's easier to find information about
> them is bad. With this argument, you can not only fight against removal of
> the NextStep prefix (Data, Number, Date… try googling that), but also
> demand that the language should be spelled "Sweeft", and that framework
> functions should loose their meaningful names and get called by a UUID
> instead.
> I don't think the `associated` keyword is cryptic; I think it's
> *specific*. "Associated type" is the name of this feature. We tried
> bikeshedding it upthread, and didn't come up with anything better. If
> you're going to use a keyword related to the name "associated type", that
> leaves you with `associated`, `type`, or `associatedtype`. Of these three,
> `type` is extremely vague (and also something we've resisted taking as a
> keyword—see the discussion about `SomeType.self` last week),
> `associatedtype` is an overlong, awkward concatenation of two words, and
> `associated` has neither of those failings. That's why I favor it.
> --
> Brent Royal-Gordon
> Architechies
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

 Wizard
james at supmenow.com
+44 7523 279 698
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20151223/ada6964e/attachment.html>

More information about the swift-evolution mailing list