[swift-corelibs-dev] Changing the name of XCTest* to Test*
brent at architechies.com
Sat Feb 27 14:03:45 CST 2016
> I’d propose that it’s important/core enough to warrant changing from “XCTestCase” to “Swift.TestCase" (et al) or something very similar.
`Swift.` would mean XCTest had been merged into the standard library, which I don't think is something we should do.
We could drop the `XC` prefixes from the APIs, giving us e.g. `XCTest.TestCase`; that might be a good idea. We could also drop the `XC` prefix from the module itself, giving us `Test.TestCase`, but I think that might be a bridge too far—we're going to start getting other testing frameworks soon enough.
More information about the swift-corelibs-dev