[swift-corelibs-dev] Changing the name of XCTest* to Test*
tony at thecocoabots.com
Sun Feb 28 18:55:24 CST 2016
> On 28 Feb 2016, at 16:45, Chris Lattner <clattner at apple.com> wrote:
> The answer is “no”. We are still planning to drop the “NS” prefix (specifically, not other prefixes) off of some imported values, but the exact details are TBD. Of course corelibs-foundation and the darwin-foundation will be kept in sync. If a type drops “NS”, we’ll drop it in both places.
> On 28 Feb 2016, at 07:03, Brent Royal-Gordon <brent at architechies.com> wrote:
> `Swift.` would mean XCTest had been merged into the standard library, which I don’t think is something we should do.
Please ignore my ignorance there. I’m (still) not across out how all the pieces fit together.
> We could drop the `XC` prefixes from the APIs, giving us e.g. `XCTest.TestCase`; that might be a good idea. We could also drop the `XC` prefix from the module itself, giving us `Test.TestCase`, but I think that might be a bridge too far—we’re going to start getting other testing frameworks soon enough.
I think this makes sense — the library is XCTest, the class is TestCase. Having XYZ.TestCase from another vendor is perfectly reasonable in my opinion.
I guess there’s a bunch of things that shake out of that though, like do you then rename XCTAssert(…) to Assert(…), etc.
It feels (oh god, the feels) like there’s an opportunity to simplify the names of some things here, but I understand there’s plenty of bigger fish to fry.
Thanks all :)
+61 411 268 532
More information about the swift-corelibs-dev