[swift-users] Is URLSession actually working on Linux

Georgios Moschovitis george.moschovitis at icloud.com
Tue Oct 3 13:10:46 CDT 2017

I implemented a simple RSS feed aggregator. I used code like...

let data = try! Data(contentsOf: feedURL)


let session = URLSession(configuration: URLSessionConfiguration.default)
let task = session.dataTask(with: url, completionHandler: completionHandler)

...to fetch the data.

While my application worked perfectly when running on macOS, when I tried to run
it on Ubuntu it started crashing randomly with errors like...

*** Error in `bin/….': double free or corruption (fasttop): 0x00007f3880000ff0 ***


Illegal instruction


When I switched to KituraRequest (in place of URLSession), the application started
running correctly on Ubuntu as well.

Are there any issues with the implementation of Foundation for Linux?


PS: I am using swift 4.0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20171003/d341ffc8/attachment.html>

More information about the swift-users mailing list