[swift-users] edit array

Ole Begemann ole at oleb.net
Wed Apr 26 11:13:57 CDT 2017

On 26.04.2017 17:01, J.E. Schotsman via swift-users wrote:
>> On 26 Apr 2017, at 16:54, Rien <Rien at Balancingrock.nl> wrote:
>> Agree, though the function should probably be named something like: withEach instead of forEach.
>> Maybe worth a proposal on evolution?
> Let’s wait until the people at the other side of the big lake have had time to react.

There have been requests for something like this on swift-evolution, 
e.g. here in the context of the discussion about a `reduce` variant that 
takes `inout` arguments: 

An alternative might be to add a variant of `map` to `MutableCollection` 
that mutates the collection directly, see: 

But as far as I know there hasn't been a proposal for adding this. (Is 
it important enough to have in the standard library? I don't know.)

More information about the swift-users mailing list