[swift-users] swiftpm linking problems

Max Howell max.howell at apple.com
Tue Feb 23 17:22:43 CST 2016

> Hello, I am having linking problems when using swiftpm, and I have burned enough time into this that I could use a nudge.
> Sample reproduction:
> I run swift build —init and swift build -v -Xcc -v. Here is the output:
> https://gist.github.com/stepanhruda/53b6e3412160d5480fcb <https://gist.github.com/stepanhruda/53b6e3412160d5480fcb>
> This seems like the simplest configuration that should work, but swiftpm cannot find any of the swift symbols. I have tried reinstalling the entire toolchain and switching xcode-select to both Xcode 7.2 and the latest 7.3 beta. Any help would be appreciated.
For some reason your installation of Swift is not linking its own standard library.

We have a number of tickets open for this, here’s one:


So far we have not been able to diagnose what is wrong, please chime in on the ticket, include as much information as possible, especially the OS X version, your Xcode version(s) and how you installed the Swift toolchain.

Sorry and thanks.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20160223/458f51e8/attachment.html>

More information about the swift-users mailing list