[swift-users] Mac Toolchain is Unsigned?

John Lin johnlinvc at gmail.com
Mon Dec 28 23:49:29 CST 2015

> On 25/12/15 15:00 , swift-users-request at swift.org <https://lists.swift.org/mailman/listinfo/swift-users> wrote:
> > Date: Fri, 25 Dec 2015 09:43:31 -0800
> > From: Dmitri Gribenko <gribozavr at gmail.com <https://lists.swift.org/mailman/listinfo/swift-users>>
> > To: swizzlr <me at swizzlr.co <https://lists.swift.org/mailman/listinfo/swift-users>> Cc:
> > Message-ID: <CA+Y5xYe001pWgacNRxB9seojwEFcboAsKMDykp8DbN0nH24ypw at mail.gmail.com <https://lists.swift.org/mailman/listinfo/swift-users>>
> >> >
> >>> While I wait for the rest of the family to arrive and the kids
> >>> are slowly going insane staring at presents, I’m doing some Swift
> >>> dev. However, I note that the latest Mac snapshot is unsigned –
> >>> has it always been this way? The installer displays the lock, but
> >>> I have to option-click on the package to actually get it
> >>> running.
> > I just checked, it is signed.  Here’s the SHA-1 hash on my end:
> > 
> > 68e2ba878d2c9803bbfda760b24b399e8ada4f79
> > swift-2.2-SNAPSHOT-2015-12-22-a-osx.pkg
> FWIW, version 1.1.5 and up of my RB App Checker Lite
> (http://brockerhoff.net/RB/AppCheckerLite <http://brockerhoff.net/RB/AppCheckerLite>) now can show signatures for
> this type of package, too.
> Enjoy,
I got some issue on verifying the code signing too.
I got Xcode 7.2 installed on Yosemite , updated to El Capitan , install toolchain.
I got "a sealed resource is missing or invalid” error when launching Xcode with the toolchain.
I tried to install toolchain again, not working.
Tried to install toolchain with debug symbol, not working.
Remove Xcode and install Xcode again, not working.
I verified the toolchain with 
odesign --verify -vvvv -R='anchor apple generic and certificate 1[field.1.2.840.113635.] exists and (certificate leaf[field.1.2.840.113635.] exists or certificate leaf[field.1.2.840.113635.] exists)' swift-2.2-SNAPSHOT-2015-12-22-a.xctoolchain
it shows the same "a sealed resource is missing or invalid”
At last I sudo remove the whole Library/Developer/Toolchains dir, then reinstall the toolchain, it finally start working.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20151229/adaad329/attachment.html>

More information about the swift-users mailing list