[swift-lldb-dev] REPL missing required module 'SwiftGlibc'

Ryan Lovelett swift-dev at ryan.lovelett.me
Wed Apr 13 13:05:08 CDT 2016

On Wed, Apr 13, 2016, at 12:18 PM, Ryan Lovelett via swift-lldb-dev
> In my latest builds (I just build
> swift-DEVELOPMENT-SNAPSHOT-2016-04-12-a) I've noticed that when I
> attempt to open the REPL and `import Glibc` the REPL reports:
> warning: <REPL>:1:1: warning: #line directive is deprecated, please use
> #sourceLocation instead
> #line 2 "repl.swift"
> ^~~~~
> #sourceLocation
> warning: repl.swift:3:1: warning: #line directive is deprecated, please
> use #sourceLocation instead
> #line
> ^~~~~
> #sourceLocation
> error: repl.swift:2:8: error: missing required module 'SwiftGlibc'
> import Glibc
> Also lldb seems to suffer from this same issue as well. If I compile a
> source and attach to the process and stop at a breakpoint it reports
> similar (e.g., `error: missing required module 'SwiftGlibc'`).
> I'd use `git bisect` to track down when it started doing that.
> Unfortunately this is probably the first time I've ever actually opened
> the REPL. So it might have been broken all along.
> Incidentally it works just find if I compile a source (`swiftc`) that
> imports Glibc.
> Is this a known issue? Any suggestions on where I should begin my
> investigation into resolving this?
> _______________________________________________
> swift-lldb-dev mailing list
> swift-lldb-dev at swift.org
> https://lists.swift.org/mailman/listinfo/swift-lldb-dev

Just to make sure it wasn't my Arch Linux distro (unsupported build)
that was exhibiting this behavior I switched over to Ubuntu 14.04.4 LTS
(GNU/Linux 3.16.0-67-generic x86_64). I then tried the exact same
commands on that machine as before. Same result.

I'm in the process of getting swift-integration-tests working on the
Ubuntu machine to run the repl tests on the downloaded *.tar.gz. It
would seem to me they should have caught this.

More information about the swift-lldb-dev mailing list