[swift-evolution] [swift-evolution-announce] [Accepted with revisions] SE-0187 “Introduce Sequence.filterMap(_:)”
dabrahams at apple.com
Tue Dec 19 17:42:52 CST 2017
> On Dec 19, 2017, at 2:28 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
> I disagree. Let’s not reopen what is settled. “Compact” can be a noun just as “map” and “filter” can; as long as there are no in-place variants, there can be no ambiguity.
> On Tue, Dec 19, 2017 at 17:11 Brent Royal-Gordon via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>> On Dec 19, 2017, at 8:56 AM, John McCall <rjmccall at apple.com <mailto:rjmccall at apple.com>> wrote:
>> Therefore, SE-0187 is accepted, with the revision that the new name be Sequence.compactMap(_:), and with the agreement that we will add Sequence.compact() when it is possible to do so.
> I like `compact` as the basis for the name, but I hope the core team will consider whether the eventual nil-removal method should be called `compacting()`, and whether therefore this method should be called `compactingMap(_:)`. Prior art on the name `compact()` does exist, but I don't think it's strong enough to justify deviating from the API Guidelines.
> I don't think we need a full review on this tiny issue; five minutes of the core team's time should more than suffice.
I agree with Brent. IMO we're firmly outside the domain of established terms-of-art here (Ruby notwithstanding).
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution