[swift-evolution] [Pitch #2] Introduce User-defined "Dynamic Member Lookup" Types

Chris Lattner clattner at nondot.org
Tue Nov 21 13:55:52 CST 2017

> On Nov 21, 2017, at 12:04 AM, David Hart <david at hartbit.com> wrote:
> I’m very happy with this new version of the proposal. Splitting into two protocols makes a lot of sense - the JSON example alone is argument enough.


> To bike-shedding: while I understand the need to keep the identifier names verbose, I would prefer the subscript label to be more representative by renaming it to dynamicMember - lookup can be interpreted as a verb, which is odd in a label.

Makes sense, I re-removed “Lookup”.

I also just added a new alternative: "Collapse the two protocols into a single one with a get-only requirement”.  It is either crazy bad or crazy good, let me know what you think.


More information about the swift-evolution mailing list