[swift-evolution] [Pitch #2] Introduce User-defined "Dynamic Member Lookup" Types
david at hartbit.com
Tue Nov 21 02:04:01 CST 2017
I’m very happy with this new version of the proposal. Splitting into two protocols makes a lot of sense - the JSON example alone is argument enough.
To bike-shedding: while I understand the need to keep the identifier names verbose, I would prefer the subscript label to be more representative by renaming it to dynamicMember - lookup can be interpreted as a verb, which is odd in a label.
> On 21 Nov 2017, at 07:36, Chris Lattner via swift-evolution <swift-evolution at swift.org> wrote:
> Hi all,
> I’ve significantly revised the ‘dynamic member lookup’ pitch, here’s the second edition:
> I’ve incorporated some minor changes to it:
> - I’ve made it possible to provide read-only dynamic members.
> - I’ve added an example JSON use-case which uses read-only dynamic members.
> - Minor wording changes.
> That said, this is significantly similar to the earlier draft. I welcome suggestions for improvements to the proposal, and insight into anything that is unclear or insufficiently motivated.
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution