[swift-evolution] [Pitch] range.contains(anotherRange)
koher at koherent.org
Wed Aug 9 00:49:09 CDT 2017
2017-08-09 12:23 GMT+09:00 Xiaodi Wu <xiaodi.wu at gmail.com>:
For consistency, the name for this function would be `isSuperset(of:)`, and
it would be equally interesting to have `isStrictSuperset(of:)`,
`isSubset(of:)`, `isStrictSubset(of:)` and `isDisjoint(with:)`--all
currently available for types that conform to `SetAlgebra`.
Thank you for your feedback. It certainly seems better to rename `contains`
to `isSuperset(of:)`. Also I'll try to implement `isStrictSuperset(of:)`
and so on.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution