[swift-evolution] [swift-build-dev] [Review] SE-0158 Package Manager Manifest API Redesign
rballard at apple.com
Tue Mar 14 11:29:37 CDT 2017
> https://github.com/apple/swift-evolution/blob/master/proposals/0158-package-manager-manifest-api-redesign.md <https://github.com/apple/swift-evolution/blob/master/proposals/0158-package-manager-manifest-api-redesign.md>
Thanks for this feedback. We'll revise it to "from:".
Since we're still making minor revisions to this proposal, I'm going to extend the review period by another day to make sure we don't have any other important feedback pending.
> On Mar 14, 2017, at 12:28 AM, David Hart <david at hartbit.com> wrote:
> Yep, after does sound confusing. I prefer from.
>> On 14 Mar 2017, at 08:22, Ankit Aggarwal via swift-evolution <swift-evolution at swift.org> wrote:
>>> – Dave Sweeris' point about this reading wrong in English as .upToNextMajor("x.y.z") (vs. of "x.y.z".upToNextMajor) makes sense to us too. As a result, we're going to clarify this by changing it to .upToNextMajor(after:"x.y.z") and .upToNextMinor(after:"x.y.z").
>> The "after" in .upToNextMajor(after: "x.y.z") sounds like we're going to pick the version after `x.y.z`, for e.g. `x.y.(z+1)`, and go upto the next major version. I think we should use `from` instead of `after`, which is more clear IMO. It also feels like `after` and `from` (in shorthand) do different things, and if we use `form`, it will also be reasonable to assume that the `.package(url:from:)` is a shorthand form.
>> - Ankit
>> swift-evolution mailing list
>> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution