[swift-evolution] [Proposal] Rename fatalError() API
davesweeris at mac.com
Fri Jan 6 17:15:33 CST 2017
> On Jan 6, 2017, at 2:58 PM, D. Felipe Torres via swift-evolution <swift-evolution at swift.org> wrote:
> Yeah, it was meant as a joke.
> I'm well aware of the uses you write about, I do that myself but felt like doing this piece based on the particular use case described in the "proposal"
I wouldn’t be horribly opposed to adding a function called “willItToCompile”, “compileAnyway”, “noSrslyIDontCare”, or some other equally explicit name, simply because that way it’d be easy to ensure that all such code was revisited before shipping the product.
I wouldn’t be horribly in favor, either, because putting a special phrase in the string that you pass to fatalError() does the same thing, and doesn’t complicate the language.
- Dave Sweeris
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution