[swift-evolution] [Review] SE-0136: Memory Layout of Values
dabrahams at apple.com
Mon Aug 8 12:16:46 CDT 2016
on Mon Aug 08 2016, Anton Zhilin <antonyzhilin-AT-gmail.com> wrote:
> Honestly, I prefer old 'size(of:)' and 'size(ofValue:)' to new
> I actually voted against that proposal. Without it, we wouldn't have
> problems we have now.
We'd have different problems:
The “problems we have now” come from over-eager removal of
functionality; they have nothing to do with whether the syntax uses free
functions or static methods/properties.
> But it's obvious now that it's just a formality to complete the
> transition. Sadly.
I'm very sorry that you're disappointed in the result, but there *was* a
review; your preferences might have had an impact, had they been aired
More information about the swift-evolution