[swift-evolution] [Review] SE-0136: Memory Layout of Values
bknope at me.com
Sun Aug 7 21:31:41 CDT 2016
Can someone quickly explain what this new API does compared to what SE-101 had?
I'm trying hard to see what's being added here but my brain isn't working
Sent from my iPad
> On Aug 7, 2016, at 10:18 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> on Sun Aug 07 2016, Karl <razielim-AT-gmail.com> wrote:
>>> * What is your evaluation of the proposal?
>> Although if I was nitpicking I prefer the name “ofInstance” (as in the
>> stdlib private function) to “ofValue”.
> The problem with “ofInstance” is that a class instance will be reported
> to be the same size as Int. Most people think of a class instance as
> the place where its stored properties live, not the reference.
>> What is the standard nomenclature? Whereas I would distinguish between
>> “objects/instances” and “values”, I’ve started referring to all Swift
>> things as “objects” and “instances”, even if they are value types.
>>> * Is the problem being addressed significant enough to warrant a
>>> change to Swift?
>>> * Does this proposal fit well with the feel and direction of
>>> * If you have used other languages or libraries with a similar
>>> feature, how do you feel that this proposal compares to those?
>> I think the metatype system needs revising for Swift >3.0, but given
>> time constraints this is the best solution
>>> * How much effort did you put into your review? A glance, a
>>> quick reading, or an in-depth study?
>> Followed prior discussion, read proposal
>>> More information about the Swift evolution process is available at
>>> Thank you,
>>> Dave Abrahams
>>> Review Manager
>>> swift-evolution mailing list
>>> swift-evolution at swift.org
> swift-evolution mailing list
> swift-evolution at swift.org
More information about the swift-evolution