[swift-evolution] [Review] SE-0136: Memory Layout of Values

Karl razielim at gmail.com
Sun Aug 7 20:03:55 CDT 2016

> 	* What is your evaluation of the proposal?


Although if I was nitpicking I prefer the name “ofInstance” (as in the stdlib private function) to “ofValue”. 

What is the standard nomenclature? Whereas I would distinguish between “objects/instances” and “values”, I’ve started referring to all Swift things as “objects” and “instances”, even if they are value types.

> 	* Is the problem being addressed significant enough to warrant a
>          change to Swift?


> 	* Does this proposal fit well with the feel and direction of
>          Swift?


> 	* If you have used other languages or libraries with a similar 
>          feature, how do you feel that this proposal compares to those?

I think the metatype system needs revising for Swift >3.0, but given time constraints this is the best solution

> 	* How much effort did you put into your review? A glance, a
>          quick reading, or an in-depth study?

Followed prior discussion, read proposal

> More information about the Swift evolution process is available at
> 	https://github.com/apple/swift-evolution/blob/master/process.md
> Thank you,
> Dave Abrahams
> Review Manager
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

More information about the swift-evolution mailing list