[swift-evolution] [SHORT Review] SE-0133: Rename `flatten()` to `joined()`
david at hartbit.com
Mon Jul 25 09:26:25 CDT 2016
> * What is your evaluation of the proposal?
+1 This makes total sense. I was going to voice my disagreement until I saw that I did not understand what the APIs did because of their names :D The renaming makes things much clearer.
> * Is the problem being addressed significant enough to warrant a change to Swift?
> * Does this proposal fit well with the feel and direction of Swift?
> * If you have used other languages or libraries with a similar feature, how do you feel that this proposal compares to those?
Even if some languages have flatten, it does seem like a special case of joined.
> * How much effort did you put into your review? A glance, a quick reading, or an in-depth study?
More information about the swift-evolution