[swift-evolution] [Review] SE-0122: Use colons for subscript declarations

Garth Snyder garth at garthsnyder.com
Wed Jul 20 14:58:42 CDT 2016


I prefer the current syntax from a subjective and readability perspective.

However, the current notation of -> Type being used to declare an input parameter to set {} just strikes me as weird and wrong. The symbol -> means “returns a” or “yields”. Since we’re declaring a type that might be either inbound or outbound, the neutral : is more appropriate.

I didn’t initially think this was all that important to address, but having considered it more, I agree that it’s a wart worth excising and is worth the disruption for users.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160720/6094e244/attachment.html>

More information about the swift-evolution mailing list