[swift-evolution] [Review #2] SE-0101: Reconfiguring sizeof and related functions into a unified MemoryLayout struct

Dave Abrahams dabrahams at apple.com
Fri Jul 15 16:56:39 CDT 2016

on Thu Jul 14 2016, Tino Heth <swift-evolution at swift.org> wrote:

> I share the minor concerns that have been expressed so far.
> My first thought on this topic ("MyStruct.size") had a obvious flaw, but I wouldn't fear name collisions with something like "MyStruct.memoryLayout.size".
> This one most likely has issues as well, but imho they aren't that
> obvious and deserve being discussed in the alternatives-section (or a
> short answer here to wake up my tired mind ;-)

We're trying to get away from “magic” properties that exist on every
type, I think.


More information about the swift-evolution mailing list